[Resolved] Top Bar Moves When Navigating Slideshow

This topic contains 12 replies, has 2 voices, and was last updated by  Andrew Misplon 3 weeks, 5 days ago.

  • Author
    Posts
  • #12885

    Karen
    Participant

    Hi there

    I’m using the Top Bar menu for my main navigation and it looks fine on the pages except when the slideshow is being used. (I am using SmartSlider). When you click through on the slider arrows the top bar disappears, or is half hidden. All the slides are the same dimensions.

    I’ve looked through the forums and have seen there’s no way to make the top bar sticky, but wondering if I can stop the jump somehow?

    Home Page

    #12887

    Andrew Misplon
    Keymaster

    Hi Karen

    You could perhaps try deactivating Smooth Scroll at Customize > Theme Settings > Navigation and see if that makes a difference.

    #12888

    Karen
    Participant

    Ok, tried that and it’s helped. Thanks for the tip.

    #12889

    Andrew Misplon
    Keymaster

    Glad that helped πŸ™‚

    #12897

    Karen
    Participant

    Hi Andrew.. Sorry to bug you again about this problem has cropped up again. I’ve switched back to the main header with navigation and got rid of the top bar for design reasons.

    If you let the slideshow autoplay, everything is ok-ish (although not very smooth), but if you click the arrows on the slideshow it jumps and part of the logo and nav is obscured. Do you see the same thing?

    I think I chose Smart Slider as it was recommended with the theme? Can’t remember how I came to use it. I think it was one of the templates you offer?

    Anyway, need a solution if you have one as I want to get rid of the jump. Smooth Scrolling is turned off.

    Thanks, Karen

    #12898

    Karen
    Participant

    P.S. I just swopped back to one of the demo sliders that comes with Smart Slider and it does the same. I guess it’s a feature of Smart Slider but not one I like really. Anyway to stop it? Or is there another slider that works better with your theme?

    #12899

    Karen
    Participant
    This reply has been marked as private.
    #12900

    Andrew Misplon
    Keymaster

    Hi Karen

    Thanks for your replies.

    You can insert a slider into the same position using Meta Slider. Alternatively, if there is no sidebar present you could also use a Full Width Stretched row in Page Builder and insert a SiteOrigin Slider or Hero widget. Those widgets don’t handle responsive resizing is quite the same way as Smart and Meta Slider would though.

    With regards to disabling the jump. There isn’t a setting to disable this feature, not that I’m aware of at the moment. It’s perhaps something you could ask Smart Slider. At the moment, I can’t find information on this particular challenge when searching.

    #12901

    Andrew Misplon
    Keymaster

    Hi Karen

    The forum uses bbPress, it doesn’t support email replies. If you’re using Ultra Premium we can move over to email support instead of the forum.

    A posts slider has historically been part of Meta Slider Pro, I’m not sure if that’s changed, the plugin was sold in the last two years so perhaps that has changed.

    What you can try to eliminate theme influences is temporarily switch to a default theme like Twenty Nineteen, insert a Smart Slider using a shortcode or widget in Page Builder and test to see if the page shifts to the slider on navigation, that’ll let you know if the theme is involved or not.

    #12902

    Karen
    Participant

    Whops. Sorry about that. Ok will try those suggestions and report back.

    Thanks Andrew

    #12903

    Andrew Misplon
    Keymaster

    Super, thanks πŸ™‚

    #12904

    Karen
    Participant

    Hi Andrew

    Got the answer. It isn’t a theme issue.

    Just heard from Smart Slide3 support. There’s an option in the Developer tab of the slider that needs to be de-activated. You have to disable the “Scroll to slider on user interaction” option. When this option is enabled (which it is by default) the browser will scroll the slider into the viewport.

    This option can be found in Slider Settings> Developer tab:

    Hopefully this info can prove useful for other users.

    Thanks, Karen

    #12905

    Andrew Misplon
    Keymaster

    That’s great news πŸ™‚ Thanks for letting me know. I’m sure other users will also find this info helpful. Glad to hear Smart Slider support could lend a hand.

    Cheers for now πŸ™‚

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Scroll to top