[Resolved] Thrive Page Builder

This topic contains 12 replies, has 2 voices, and was last updated by  Andrew Misplon 10 months, 4 weeks ago.

  • Author
    Posts
  • #8328

    Simon Social Media
    Participant

    Hi,

    I have installed the Thrive Architect Page Builder to help with creation of a Landing Page. At the moment I can edit a page with the plugin but when I preview a layout change the change is not recognised. Also, only the default landing page template is shown when I go back to preview my page so changes within Thrive are not saving back to my Page.

    I have been over to the Thrive Forum and they have investigated. The tell me a default theme works fine and hence this is probably something to do with the theme I’m using (Ultra). Can you help?

    Regards
    Simon

    #8329

    Andrew Misplon
    Keymaster

    Hi Simon

    Thanks for your post.

    If you deactivate all plugins except for Thrive and leave Ultra activated, does the issue persist? If so, are there any Console errors present in the WP admin around the time of the issue?

    https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors#Step_3:_Diagnosis

    #8333

    Simon Social Media
    Participant

    I get this error:

    (index):517 WebSocket connection to ‘wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data’ failed: Error during WebSocket handshake: Unexpected response code: 403

    #8334

    Andrew Misplon
    Keymaster

    So the issue persists with all other plugins deactivated and only Ultra activated? Please, can you confirm.

    Please, also test on your site, all plugins except for Thrive deactivated, Twenty Sixteen activated as your theme.

    (The support thread you’ve referenced isn’t public. Thrive isn’t free so this, unfortunately, isn’t easy for me to test.)

    #8335

    Andrew Misplon
    Keymaster

    If you’re using a caching plugin, it must be cleared before its deactivated.

    The console error you’ve mentioned is a Jetpack error. Was Jetpack deactivated? I’m not sure you’d still see this connection attempt with Jetpack deactivated?

    https://wordpress.org/support/topic/error-after-installing-jetpack-2/
    https://stackoverflow.com/questions/36900447/websocket-connection-failure-error-during-websocket-handshake-response-code-40

    #8336

    Simon Social Media
    Participant

    Hi Andrew,

    I’ve now removed everything apart from Thrive and switch to Twenty Sixteen. Thrive now works as expected.

    If I switch to Ultra Premium with only Thrive activated, Thrive does not work as expected.

    What do we do next?

    Thanks
    Simon

    #8337

    Andrew Misplon
    Keymaster

    You’d need to try find an error. The console error is from Jetpack, if Jetpack is deactivated you shouldn’t see that. The next step would be to turn on debug and see if there is a PHP error present:

    https://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG

    #8338

    Simon Social Media
    Participant

    Ok, the only error I get in Java console is:
    Slow network is detected. Fallback font will be used while loading: http://www.simonsocialmedia.com/wp-content/themes/ultra/font-awesome/fonts/fontawesome-webfont.ttf?v=4.7.0

    #8339

    Andrew Misplon
    Keymaster

    Thanks. So next, you’d need to enable debug to check for PHP errors.

    #8340

    Simon Social Media
    Participant

    Hi – thanks for your help. I switch to the Divi theme and this resolved the issue so I’ve migrated to that theme.

    #8341

    Andrew Misplon
    Keymaster

    No problem. Sorry I couldn’t help further. Without any errors present in the console the next step was to turn on debug which is why I sent those instructions and see if any PHP errors were presenting. With an issue like this, I’d need a starting point to investigate the issue, some hint of where the issue is coming from.

    All the best 🙂 Cheers.

    #8342

    Simon Social Media
    Participant

    No worries Andrew, I appreciate your support. I had been thinking of a refresh after running Ultra for two years so now seems a good time to do that. All the best yourself. Simon.

    #8343

    Andrew Misplon
    Keymaster

    Perfect. Nice to get a new look going. Thanks for your understanding 🙂

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Scroll to top