[Resolved] IE11 Problem

  • Author
    Posts
  • #6264

    haojie
    Participant

    Because of the WordPress and Ultra Theme, I can build my own website, thanks a lot.

    The problem is when I open my website via IE, it doesn’t display normally.
    The icons in the top bar and SiteOrigin Features are all disappeared.
    The social links in Top Bar Social Menu displays vertically one by one. Also the icons are gone.
    The Primary Menu and Footer Menu also display vertically.
    The third picture in the Home Slider is not stretched, but with other browsers it is stretched.
    It seems the page is not wide enough, the contents don’t display in one row while they do in other browsers.

    Thank you very much.

    IE Version: 11.953.14393.0
    Windows 10
    My Website: http://www.haoruilighting.com

    #6265

    Andrew Misplon
    Keymaster

    Hi 🙂

    Please, can you check if these issues are happening when you view the demo: http://demo.purothemes.com/ultra.

    SSL has expired, I’ll sort it out today, please, click Advanced and pass through the warning screen. Thanks.

    #6266

    Andrew Misplon
    Keymaster

    You can also try testing your own site right away without caching. Go to your caching plugin, clear the cache and then deactivate the caching plugin and re-test.

    #6273

    haojie
    Participant

    Hi, thanks for your kind reply.

    I tried the demo and my site, clear the cache, but the issues still happened.

    Is there anything else I can try?

    #6274

    Andrew Misplon
    Keymaster

    Thanks. What is the result when you view the demo site? That’s a test, does it look normal?

    #6275

    Andrew Misplon
    Keymaster

    With regards to the caching plugin, did you deactivate it after clearing its cache?

    #6280

    haojie
    Participant

    Sorry I failed to upload the screenshots.

    The demo site displayed the same as my site.

    I checked the “Delete Browsing History When Exit”, the history includes temporary internet and site files. And in the settings I did not check the “Allow to Use Cache and Database”

    • This reply was modified 5 years, 7 months ago by haojie.
    #6283

    Andrew Misplon
    Keymaster

    Thanks. It sounds like you are using an old I.E. version in IE11. On your keyboard click F11 to open dev tools and somewhere there it’ll tell you what version you are rendering with, I suspect it’s an older version. I am on my phone today but wil send you screenshots later tonight GMT+2

    #6284

    haojie
    Participant

    Thank you, you are right.

    When I opened the dev tools and turned to the Emulation tool (CTRL+7), I found the default document mode is 7. When I chose 11, the site turned to normal.

    So can it be solved? Render at least IE9?

    #6285

    Andrew Misplon
    Keymaster

    Super, glad we’re making progress.

    Unfortunately, not. There are so many CSS3 rules we can’t use for older versions of IE. Ultra uses a few JavaScripts to help older browsers so we’ve done all we can do. Officially, we support the current version and one version back of major browsers. For IE we’ve gone further back than that but IE9 is unfortunately, just missing far too much. Sorry I can’t assist further.

    #6286

    Andrew Misplon
    Keymaster

    If you switch the renderer to IE11, things should go back to normal.

    #6287

    haojie
    Participant

    Yes, you are right, thank you.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Scroll to top