[Resolved] Blog title not showing on Blog page

This topic contains 9 replies, has 2 voices, and was last updated by  Andrew Misplon 4 months, 1 week ago.

  • Author
    Posts
  • #8575

    SydneyJB
    Participant

    Please see site at https://veganmichiana.com. I cannot understand how to get the simple word Blog to show up at top of Blog page. Not as a breadcrumb because I have turned off the breadcrumbs as redundant to a page title.

    Both Blog page and Events page have no titles. Would love to have a title for Events page, too. Help and thank you!

    #8576

    Andrew Misplon
    Keymaster

    Hi Sydney 🙂

    Thanks for posting. WordPress doesn’t render any content besides the posts feed on the blog page. One method would be to use Page Builder by SiteOrigin on the blog page. You don’t need to use Page Builder anywhere else if you don’t want to. With Page Builder activated, disable your posts from Settings > Reading (deselect blog page). Then, go to your blog page, click on the Page Builder tab, click Add Widget, insert the Post Loop widget and select the Blog template from the drop-down list. Save the page.

    #8580

    SydneyJB
    Participant

    Ok, I can do that. But I thought that it said everywhere that the title Blog shows by default. But mine doesn’t even show that. I wasn’t expecting other text to show, though on another site I would like to add text as intro to blog. But shouldn’t the Blog title of “Blog” show?

    Also, can I use the method you mentioned above for the Events Calendar. It’s a plugin that doesn’t show the title of Events on its page. Just wondered if you know.

    Thanks,
    Sydney

    #8581

    Andrew Misplon
    Keymaster

    Thanks, I’m with you.

    Partially walking back my previous reply. It’s a theme level decision. For example, if you test Twenty Sixteen theme the page title won’t display, but it will in Twenty Seventeen. If you don’t want to proceed with the Page Builder solution I mentioned, we could look at a child theme solution for you.

    For a Page Builder, Events Calendar fix you’d need to create a new page, insert one of the Events Calendar widgets into the page and then link to that page as your main events page.

    #8582

    SydneyJB
    Participant

    So Polestar is set not to show it, is that right?
    I do have a Polestar-child theme already set up so, yes, I can go with child solution if you can help me with it. Something for the functions.php??

    If not, I can proceed with Page Builder.
    Thanks,
    Sydney

    #8583

    Andrew Misplon
    Keymaster

    That’s correct. It isn’t templated that way in the same way that it isn’t set to show in Twenty Sixteen. For the majority of users this is desired. Sorry it isn’t what you’re after, wish I could help both cases. In Ultra I had a setting but was trying to reduce the number of settings in this theme.

    Let me work something up for you…

    #8586

    Andrew Misplon
    Keymaster

    Download, unzip and then upload the PHP file to your child theme folder:

    https://purothemes.com/wp-content/uploads/2018/01/index.php_.zip

    #8587

    SydneyJB
    Participant

    Thanks very much. Will give this a try next. You went above and beyond. 🙂

    #8588

    SydneyJB
    Participant

    That worked perfectly. Thank you very much, Andrew.

    #8589

    Andrew Misplon
    Keymaster

    Super 🙂 Glad to hear that helped. All the best.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Scroll to top