[Resolved] Blank Page for Blog Posts

This topic contains 17 replies, has 2 voices, and was last updated by  daviestorres 2 months ago.

  • Author
    Posts
  • #7798

    daviestorres
    Participant

    I am using the Ultra Theme with a Staic Front Page and Blog Posts in a News Page

    I have recently been getting a completely blank webpage (the whole window is grey) for my News Page. If I preview the site using a different theme, then it all appears correct.

    I have deleted the News page and recreated it but that didn’t fix the issue.

    Any ideas?

    The site is http://www.daviestorresdesign.co.uk

    Russell

    #7799

    Andrew Misplon
    Keymaster

    Hi Russell

    Can you perhaps set wp-debug to true so we can see if any errors are showing there?

    https://codex.wordpress.org/Debugging_in_WordPress

    #7843

    daviestorres
    Participant

    I have set it to true now. It showed an error with another plugin called Job Manager so I deactivated that one.

    I no longer get error messages but I still get a blank page.

    Thanks

    #7844

    Andrew Misplon
    Keymaster

    Thanks for your feedback.

    Try deactivating all plugins not authored by SiteOrigin, does the issue still occur?

    #7845

    daviestorres
    Participant

    All plugins are deactivated now and it gives a blank page for the news.

    #7846

    Andrew Misplon
    Keymaster

    Other things to try:

    1. Does the same issue occur if you go to Settings > Reading and assign the posts page to another page, not News, some other page?

    2. Install and activate https://wordpress.org/plugins/server-ip-memory-usage/. Check the footer in the WP admin, what percentage of PHP memory are you using and what is the maximum allowed?

    3. Switch to another theme, delete Ultra and reinstall it from Themes > Add New, use the search bar top right to locate it.

    #7847

    daviestorres
    Participant

    Answers

    1. Does the same issue occur if you go to Settings > Reading and assign the posts page to another page, not News, some other page?. The blank page moves to wherever the blog posts are assigned to go.

    2. Install and activate https://wordpress.org/plugins/server-ip-memory-usage/. Check the footer in the WP admin, what percentage of PHP memory are you using and what is the maximum allowed? Here is what is in the footer Memory: 8 of 256 MB (3%) | WP LIMIT: 40 MB | IP (gale) | PHP 7.1.8 @32BitOS

    3. Switch to another theme, delete Ultra and reinstall it from Themes > Add New, use the search bar top right to locate it. Will I have to rebuild the site after I do this?

    #7848

    Andrew Misplon
    Keymaster

    3. No, you won’t lose any WordPress content or settings but you will lose code customisations. Have you customised the theme at a code level at any time?

    #7849

    daviestorres
    Participant

    You can probably tell by my answers before but no I have not modified any code

    #7850

    Andrew Misplon
    Keymaster

    There is no way back without a hosting level backup if you have so it’s good for us to confirm 🙂

    Ok cool, switch themes, delete and re-install Ultra. If that doesn’t help, please, go to Users > Add New, create an Administrator role account:

    Username: puro
    Email address: support@purothemes.com

    Opt to have the password emailed.

    I’ll login and try assist further. No new ideas yet.

    #7851

    daviestorres
    Participant

    OK – you should have received an email with login details

    I deleted the theme and then reinstalled it. Then activated the usual plugins and I still get the blank page.

    Thanks for your help.

    #7852

    Andrew Misplon
    Keymaster

    Thanks. Please, can you also try increasing WP Memory limit in your wp-config.php file to 256 and see if that helps at all.

    define( 'WP_MEMORY_LIMIT', '256M' );

    Insert into wp-config.php file just after:

    define( 'WP_DEBUG', false );

    #7853

    Andrew Misplon
    Keymaster
    This reply has been marked as private.
    #7854

    daviestorres
    Participant

    OK – Done

    #7855

    Andrew Misplon
    Keymaster

    The browser console is throwing the following error:

    GET http://www.daviestorresdesign.co.uk/news/ 500 (Internal Server Error)

    I’ve upgraded my local setup to match your servers PHP version and still can’t replicate the issue. This isn’t something I’ve seen before.

    I can hotfix the issue for now using Page Builder by SiteOrigin and a Post Loop widget. I’ve done that. If you’d like me to try and find the root cause, please, send me your FTP details via email to support@purothemes.com. I can take a look on Friday.

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.

Scroll to top