[Resolved] Spacing above footer area

This topic contains 8 replies, has 2 voices, and was last updated by  Andrew Misplon 7 months, 4 weeks ago.

  • Author
    Posts
  • #6080

    provwp
    Participant

    Hi,
    I am using Ultra Premium theme. The Home page is designed with SiteOrigin Page Builder layout. Towards the bottom of the page, there is an extra space between the text widget (that contains social media icons) and the Footer bar. Could you please help, how to remove this space?

    I tried this style in the custom CSS:
    #colophon .widget {
    padding: 0 0 0 0;
    }

    Also tried:
    Customize -> Theme Design -> Footer, Footer Padding (px) to 0
    Still the space is not disappearing.

    Website: http://beta.vedantaprov.org/

    #6083

    Andrew Misplon
    Keymaster

    Hi, thanks for your support. Please try editing the page via Pages and setting the Page Template to Default and then disabling the Footer Margin setting. You’ll also need to set the Layout to No Sidebar. Hope that helps.

    #6085

    Andrew Misplon
    Keymaster

    More on Page Settings here: https://purothemes.com/documentation/ultra-theme/page-settings/. Template must be set to Default before properly using Page Settings. Thanks.

    #6088

    provwp
    Participant

    Many thanks, Andrew. That helped.
    Thanks again for your quick reply.

    #6090

    Andrew Misplon
    Keymaster

    Awesome 🙂 Glad that helped. All the best.

    #6108

    provwp
    Participant

    Andrew,

    The margin for footer was removed only if I use “Page Builder Home” in Template as seen in the homepage now (http://beta.vedantaprov.org). If I use “Default Template” the gap remains. I can continue to use “Page Builder Home” in Template option – that is not a problem, but I just want to let you know what solution actually worked for me.

    Second issue: How can I remove the top-bar (red band)? I toggled off “Top Bar” in Appearance>Customize>Theme Settings>Header. I also toggled off top-bar in Appearance>Home Page>Edit as page>Page Settings (I used “Default Template” here as you advised, which brings the footer top-margin back as mentioned above). The bar still appears as seen now. The interesting part is: it shows links for many pages there even though Appearance>Customize>Theme Design>Menus>Top Bar has “Automatically add new top-level pages to this menu” toggled off (IMG1). At this exact place (Appearance>Customize>Theme Design>Menus>Top Bar), “Display location” of “Top Bar Menu” was not chosen (IMG1 in the link below). However, if I choose this location as “Top Bar Menu”, then the Top-bar has no pages and it is all blank as expected, nevertheless the red band is still present (IMG2 in the link below) – I need to remove this band. Note that in Appearance>Customize>Theme Design>Menu Locations>Top Bar Menu has been given as “Select” all the time. Any comments on this please?
    Link: http://vedantaprov.org/query.html
    I hope this query was not confusing :-). Please let me know if you need more clarity.

    Regards,
    Srikanth

    #6109

    Andrew Misplon
    Keymaster

    Hi Srikanth, please, create a new Admin account and I’ll take a look:

    Username: puro
    Email: support@purothemes.com
    Send new password to user: Enable

    Thanks.

    #6110

    provwp
    Participant

    Andrew,

    I created the username with admin rights. I just had the option “Send an email to the user about the account” – I checked that in. I hope you could login.

    Regards,
    Srikanth

    #6111

    Andrew Misplon
    Keymaster

    Thanks, we should be fixed now.

    Footer Margin
    At Theme Settings > Blog the Edit Link option was enabled. This edit link only shows for admin and is a shortcut link. It does add it’s own gap above the footer but wouldn’t be visible to logged out users. I’ve disabled this setting. You can now use Default Template with Page Settings.

    Top Bar
    There might have been an update to header.php since you included it in your child theme. The top bar partial needed a conditional around it, I’ve updated header.php in the child theme for you.

    Please, check the Plugins page to make sure I activated all the correct plugins after I did a plugin conflict test. Thanks 🙂

    Hope this helps.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Scroll to top