Responsiveness different on desktop and laptop screens

This topic contains 1 reply, has 2 voices, and was last updated by  Andrew Misplon 3 years, 2 months ago.

  • Author
    Posts
  • #1265

    Matt240368
    Participant

    I have come across an issue that could possibly be an issue with using the Page Builder plugin so I am not sure if it’s relevant to the Ultra theme, but I am using the Ultra theme while this is happening so I figured I would try here first and then contact the Page Builder support if that would be a more appropriate action.

    On my home page I use a fair number of Visual Editor widgets within Page Builder which have been a key component of the effectiveness of my site using the Ultra theme. On my laptop it works great, however when I look at my site from a desktop screen the responsiveness of the text is inadequate.

    As the screen is minimized, on my laptop and my desktop; the items become compressed, causing the text to respond accordingly. On my desktop, there are full words that will get separated when there is a line break whereas on my laptop the line breaks are determined by the spacing between words. Here is an example of what I am talking about.

    Laptop: “preserve your
    creativity.”

    Desktop: “preserve your creat
    ivity.

    If you know of a possibility for a solution, would you please let me know what would be the most appropriate action for me to take in resolving this issue? Also if I should contact Page Builder support just let me know…

    Best regards,
    Matt

    #1266

    Andrew Misplon
    Keymaster

    Hi Matt

    Thanks for giving Ultra a try and reaching out with this feedback. I think I’ve resolved the problem and have included in the fix in the next version which I’ll release ASAP.

    In the mean time you could hotfix as follows; first download a Custom CSS plugin if you don’t have one installed already. I quite like Simple Custom CSS: https://wordpress.org/plugins/simple-custom-css/. To avoid plugin bloat, first check if you are using Jetpack. If you are, rather go to Jetpack > Settings and activate Custom CSS, that way you won’t need another plugin.

    With one of the above Custom CSS plugins ready, proceed to Appearance > Custom CSS (Custom CSS) or Appearance > Edit CSS (Jetpack) and insert the following:

    /* Paragraphs: Can remove after Ultra 0.9.4 */
    p {
        white-space:pre;
        white-space:pre-wrap;
        white-space:pre-line;
        white-space:-pre-wrap;
        white-space:-o-pre-wrap;
        white-space:-moz-pre-wrap;
        white-space:-hp-pre-wrap;
        word-wrap:break-word
    }

    Give that a try and let me know how it goes.

    If you run into another challenges, please let me know. You’re also welcome to ask me about anything Page Builder or SiteOrigin Widgets Bundle related.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Scroll to top