Social Menu

This topic contains 8 replies, has 2 voices, and was last updated by  Andrew Misplon 3 years, 4 months ago.

  • Author
    Posts
  • #1411

    amylynpace
    Participant

    Hello.
    How do I use the Social Menu feature? I would like to add my Facebook page to the Top bar… can’t find where to add my Facebook page ID, etc.,
    I have found where to activate the social menu, but it only displays little boxes. Also, the same little boxes are displayed next to the phone number, etc. DO I have to enable the ultra font somehow?

    he link in your documentation regarding creation of and use of Social Menu is broken.

    robinwaydairy.com

    Thank you!

    #1413

    Andrew Misplon
    Keymaster

    Hi amylynpace

    Thanks for your support.

    Please get in touch with your hosting company and let them know that your theme requires access to the following files:

    http://robinwaydairy.com/wp-content/themes/ultra/icons/fonts/ultra-icons.woff?-cu086y Failed to load resource: the server responded with a status of 404 (Not Found)
    http://robinwaydairy.com/wp-content/themes/ultra/icons/fonts/ultra-icons.ttf?-cu086y Failed to load resource: the server responded with a status of 404 (Not Found)

    Some hosts block certain file types for security reasons. It’s usually a relatively quick process to get the Ultra font files un-blocked.

    Please find the social menu tutorial here: https://purothemes.com/documentation/general-wordpress/social-icons-menus/. There is a video at the bottom of the page if you’d like a quick visual run through.

    Looks like your doing great work with Custom CSS. If there is anything I can assist with, please let me know.

    Let me know how the icon challenge goes too.

    #1414

    amylynpace
    Participant

    I have ftp and cpanel access, can I unblock them myself? Thanks for the link!

    #1415

    amylynpace
    Participant

    Hi again. The host replied that they don’t block fonts, which they point out is proven by the fact that the other custom fonts (the arrows on the meta slider, for example) are displaying just fine. Could there be a problem with the path to the ultra-icons fonts? Thank you.

    #1416

    amylynpace
    Participant
    This reply has been marked as private.
    #1417

    Andrew Misplon
    Keymaster

    Thanks for diving in. What we should have asked your hosts is to confirm those files are there (they are) and then ask them why they are returning a 404 not found error in the browser. Apologies. That would have been the way to phrase the question.

    Here is a little info on why you’re seeing query strings appended to those urls:

    Ultra uses Icomoon:

    Icomoon appends query string parameters (everything after the ?, in this case -w9xgwa), to either distinguish the font you were served from others generated, or more likely, to break the cache when your font is updated. Your font when served to users is likely cached (so they don’t have to download it each time they view your page). Appending the query string, and changing it will cause the user agent to download it again.

    Ref: http://stackoverflow.com/questions/21683281/bulletproof-font-face-syntax-subtleties

    Although your hotfix works now, the files will unfortunately be overwritten in the next update and return to their previous state.

    I also work at SiteOrigin in a Support capacity. We’ve seen this problem come up with our own custom fonts a few times, each time it would seem that the host managed to resolve it. I unfortunately don’t have any further details on what steps they took.

    #1418

    Andrew Misplon
    Keymaster

    (If you happen to be working off a Windows based server (IIS), this is a relatively in-depth thread on the problem: http://stackoverflow.com/questions/4015816/why-is-font-face-throwing-a-404-error-on-woff-files)

    #1419

    amylynpace
    Participant

    On your advice, I read some more articles and posts regarding 404s with query strings. Many pointed to there being a single character that was causing the 404 – for example, a period. So I tried just removing the hyphen from the string and it worked. You all know much more about this than I do. Is that okay? Will the parameter still function without the hyphen? I have never worked with the particular web host before, and I am not enjoying their lack of response to my tickets. When they do respond, they basically copy and paste from their online documentation. I got nowhere fast.

    #1420

    Andrew Misplon
    Keymaster

    Sure, it’ll still work without the hyphen. In the next update I’ll update the query so that it doesn’t include a hyphen. Hopefully that’ll help 🙂

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Scroll to top