Remove 'Content Header'

This topic contains 15 replies, has 2 voices, and was last updated by  Andrew Misplon 2 years, 5 months ago.

  • Author
    Posts
  • #2711

    Dan Blackadder
    Participant

    Hi,

    I am looking to remove the content header from the Ultra Premium theme.

    I have so far failed at creating a child theme for the Ultra Premium that works and inserted various texts of code into a custom css plugin I have installed, and neither have worked.

    To be honest, I would have thought with a Premium theme I would have been able to disable this by a tick button?

    Any help is appreciated! Thanks.

    #2713

    Andrew Misplon
    Keymaster

    Hi Dan

    Thanks for your support. Sorry to hear you’ve had trouble on this point. Please, reach out if anything further comes up and I’ll do my best to assist quickly and save your time.

    On any page you can select Full Width – No Title from the Page Template drop down menu in the right column. That’ll remove the page heading and the entire content header from the source code, not just with CSS. Would this cover your needs or are you also looking to hide the content header on posts?

    #2718

    Dan Blackadder
    Participant

    Hey Andrew,

    Will do, thank you.

    I have done this, and still find there is an unnecessary amount of space in-between the content and the header. How can I change this?

    #2720

    Andrew Misplon
    Keymaster

    Thanks for your understanding.

    If your Custom CSS wasn’t working you might remove it so you have a clean slate to work with. Try adding:

    /* Main Content Container */
    
    .page-template-full-width-no-title .site-content > .container {
    	padding-top: 3.57143em;
    }

    Adjust the value as required. The value above is default so you will need to make a change before seeing it on the front end. Although it’s an em value now you can use px. For example:

    /* Main Content Container */
    
    .page-template-full-width-no-title .site-content > .container {
    	padding-top: 10px;
    }

    Let me know how that goes.

    #2727

    Dan Blackadder
    Participant

    I think that has fixed it for the home page.

    I am now having issues with woocommerce, on the shop page it was still showing the breadcrumb at the top of the screen? I have now deleted the pages in an attempt to start again, however uninstalling and reinstalling woocommerce hasn’t taken me to the setup that I originally had, if you could point me in the right direction to fix this, and remove the breadcrumb from this page?

    Thank you in advance.

    #2728

    Dan Blackadder
    Participant

    I can google it, don’t worry lol. Was me just being lazy.

    Thank you for all your help. I will attempt to work out the rest.

    #2729

    Andrew Misplon
    Keymaster

    No problem 🙂 Replying now.

    #2730

    Andrew Misplon
    Keymaster

    Mmm, I might need to take a look a look at that. I know that I’ve unhooked the default WooCommerce breadcrumb and reinserted it in the Ultra breadcrumb position but now that you mention it, I don’t think it’s conditionally tied to the Ultra breadcrumb theme setting. If you can share a link with me (there is a private reply option below) I can help remove it using CSS. Thanks for your feedback.

    #2731

    Andrew Misplon
    Keymaster

    For pages you can go to WooCommerce > Settings > Display > Settings and set a page as your Shop page from there.

    For other pages you can create them and then insert the appropriate shortcode:

    https://docs.woothemes.com/document/woocommerce-shortcodes/

    #2733

    Dan Blackadder
    Participant
    This reply has been marked as private.
    #2736

    Dan Blackadder
    Participant
    This reply has been marked as private.
    #2737

    Andrew Misplon
    Keymaster

    Super 🙂 Glad I could help.

    Please, try the following for the WooCommerce breadcrumb problem:

    /* WooCommerce */
    
    .woocommerce .container .woocommerce-breadcrumb { display: none; }

    If you’d prefer them gone from the source code too, I’d be happy to look at a child theme solution tomorrow. Just let me know.

    #2739

    Andrew Misplon
    Keymaster

    Ahh, ok, just got your screenshot. One moment…

    #2741

    Andrew Misplon
    Keymaster

    Try this instead:

    /* WooCommerce */
    
    .woocommerce .entry-header {
      background: #fff;
      padding-top: 0;
      padding-bottom: 10px;
    }
    
    .woocommerce .entry-header h1.entry-title,
    .woocommerce .container .woocommerce-breadcrumb { 
      display: none; 
    }

    Set #fff to match your background and 10px to the padding you’d like there.

    #2743

    Dan Blackadder
    Participant

    Legend, thank you so much dude!

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.

Scroll to top