Javascript Conflicting with Meta Slider

This topic contains 4 replies, has 2 voices, and was last updated by  Andrew Misplon 2 years, 11 months ago.

  • Author
    Posts
  • #2134

    sfsternberg
    Participant

    I am using the ultra theme and have upgraded to meta slider pro. I am using the button plugin with meta slider to allow for links on my home page slider.
    http://www.starhill-partners.com

    Issue:
    There’s a conflict between Meta Slider and the Ultra theme, when a link is inserted into a layer the whole slide becomes a link.

    The ‘Background Image Link’ field is not populated in Meta Slider settings.

    In the theme’s JavaSript file there is code that looks like it’s supposed to ignore Meta Slider from turning the slide into a link but perhaps this isn’t working when a link is added to a layer?: http://starhill-partners.com/wp-content/themes/ultra/js/jquery.theme.min.js?ver=1.0

    The support group located this issue above, I do not have experience with JS so would need direction on what to change if I had to.

    • This topic was modified 2 years, 11 months ago by  sfsternberg.
    • This topic was modified 2 years, 11 months ago by  sfsternberg.
    • This topic was modified 2 years, 11 months ago by  sfsternberg.
    #2138

    Andrew Misplon
    Keymaster

    Hi sfsternberg

    Thanks for your support and sorry to hear about the hassle.

    jquery.theme.min.js is Ultra’s main JS file. It handles most of the theme’s JS functionality. That’s to say, there are many elements within the file handling lots of different tasks.

    1. Did Matcha Labs give any further details regarding where the conflict is within that file?
    2. When you say you’re using the “button plugin” can you perhaps confirm what that is?

    Besides the above two questions, please, can you also try testing the following:

    1. Appearance > Theme Settings > Home. Disable the setting that reads Stretch Home Slider.
    2. Instead, use the Meta Slider full width functionality, you can find that at Meta Slider > Advanced (right column) > 100% width.

    The way Ultra stretches Meta Slider might be conflicting with the Pro version and it’s layering abilities.

    #2139

    Andrew Misplon
    Keymaster

    Thanks for the thread update, I posted my reply before seeing your update.

    1. Don’t use Ultra’s stretch setting, instead, use the Meta Slider stretch setting as I indicated above.

    Let me know if that helps.

    #2140

    sfsternberg
    Participant

    Hi Andrew,

    I disable Ultra’s home stretch setting and that seems to have done the trick! Thank you 🙂

    #2141

    Andrew Misplon
    Keymaster

    Super, glad to hear that helped 🙂 Apologies for the hassle.

    If anything else comes up, please, let me know.

    All the best with your site.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Scroll to top