[Resolved] Iframe Bug on SO Builder

This topic contains 4 replies, has 2 voices, and was last updated by  Andrew Misplon 3 weeks, 2 days ago.

  • Author
    Posts
  • #10796

    David Calderwood
    Participant

    I’ve noticed that if I add an iframe I get edit problems on the page. I am using Ultra Premium theme,

    CODE: <iframe src="https://player.html5tap.com/v1/html5big.html?jdata=https%3A%2F%2Festeemlivemusic.com%2Fhtml5tap%2Fjakes-country%2F" frameborder="0" marginheight="0" marginwidth="0" scrolling="no" width="347" height="414"></iframe>

    I have tried adding with the following widgets in SiteOrigin Page Builder: wp text, custom html, SO editor – and I get the same result. I enter code, update page, view online and all is good. Go back to the page and select the widget to edit, and SO Page Builder crashes with a blank page displaying the time (image below). It is impossible to re-edit the widget with the iframe. I can edit all other widgets. I can delete the iframe widget.

    I have tried to reproduce the same error with SiteOrigin Vantage theme and all works ok, so I’m assuming that it is related to Ultra theme. Also, I use SO premium.

    Screen shot of error

    #10797

    Andrew Misplon
    Keymaster

    Hi David

    Thanks for reaching out.

    The date outputting when you open a widget is a common sign that Wordfence, for whatever reason, has incorrectly flagged the request. To resolve this please navigate to WP Admin > Wordfence Tools and open the Live Traffic tab. Filter by Blocked by Firewall and search the request you just made, it’ll be associated with your user account and the parm will start with body: instance=%7B%22frames%22%3A%5B%7B%22content. Click Whitelist param from Firewall.

    #10802

    Andrew Misplon
    Keymaster

    Hi David. Super, glad to hear that helped πŸ™‚

    (Unfortunately, the forum doesn’t support email replies at the moment.)

    All the best πŸ™‚

    Andrew

    #10805

    David Calderwood
    Participant

    Yes, thank you for the response. Wordfence was in fact blocking the calls through the firewall. Adding to the whitelist has fixed the issue.

    Thanks for the excellent theme and support.

    #10806

    Andrew Misplon
    Keymaster

    Super πŸ™‚ Glad we could resolve this quite quickly. Let me know if anything else comes up.

    Cheers for now πŸ™‚

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Scroll to top