[Resolved] Blog Page sidebar cannot be disable

This topic contains 4 replies, has 2 voices, and was last updated by  Andrew Misplon 1 year, 1 month ago.

  • Author
    Posts
  • #6652

    flim
    Participant

    Hi, I am a noob in WordPress.

    I want to turn off the sidebar in blog Post Page, In Page Settings->Page Layout, I have select ‘No Sidebar’, however Blog Posts page still shows the sidebar. Is there any way to turn off the sidebar?

    #6698

    Andrew Misplon
    Keymaster

    Hi flim

    Thanks for posting your question and for the wait. At the moment Page Settings only work with pages, once we assign a page to be our posts page (blog) from settings reading it becomes an archive page. So, the workaround we can do is as follows:

    1. Go to Settings > Reading and deselect the posts page. Make sure no posts/blog page is selected.
    2. Assuming you have Page Builder by SiteOrigin installed and activated, go to your Blog page and click on the Page Builder tab.
    3. Click Add Widget and insert a Post Loop widget, you can search for it to find it.
    4. In the Post Loop widget, select the Blog template.

    Everything will be the same as before with the exception that we’re now working on a normal page so Page Settings (Page Layout > No Sidebar) will take effect. Another advantage of this method is that you could now insert content into Page Builder above or below the Post Loop widget which isn’t possible with a normal blog page designation.

    (One last way of doing this would be to use Jetpack Widget Visibility and set all sidebar widget visibility to not display on the blog/archive page, that would remove the sidebar. Just mentioning this for interest sake.)

    If you have any further questions or follow-up on this question, please, let me know 🙂

    #6743

    Andrew Misplon
    Keymaster

    Hi flim, let me know how this went when you have a free moment.

    #6759

    flim
    Participant

    Hi Andrew,

    Yes, I don’t need the archive page, deselect the Posts page works! Haven’t try the Post Loop widget, I have tested different blog plugin to show the post.

    Many thanks! I really like this theme!

    #6761

    Andrew Misplon
    Keymaster

    Super, glad to hear you’re making progress 🙂 Thanks for the update.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Scroll to top