How to Disable Drop Down Menus


  • Author
  • #3238


    Is there a way I can disable the drop down menu feature in the top menu?


    Andrew Misplon

    Hi tobywan

    Thanks for reaching out 🙂

    The easiest way to do this would be to go to Appearance > Menus, create a custom menu for the top bar menu location and assign your menu to this location. In this way you could ensure that the menu displayed in the top bar doesn’t have any drop downs.

    Hope this helps. Let me know if you have any follow-up questions.


    Heikki Visnapuu

    Hi, I have opposite problem, dropdown does’nt appear.


    Andrew Misplon

    Hi Heikki

    Thanks for reaching out.

    It’s possible there is a plugin conflict preventing Ultra’s drop down menus from working normally. To test this out, please, try the following instructions:

    You can start by disabling all non-SiteOrigin plugins and see if this fixes the issue. You’ll need to clear all your caches after disabling your plugins. So just to confirm, double check if the issue is coming up while all other plugins are disabled.

    If it does fix the issue, then try re-enabling your plugins one by one until the issue comes back. This procedure will help diagnose which plugin is causing the issue. Once we know that, we’ll be able to look at what might be causing the conflict and either solve the problem or help you find an alternative plugin.

    Let me know how this goes 🙂


    Heikki Visnapuu

    Hi Andrew, the reason was Jetpack plugin part Photon. After disabling just Photon menus OK again.


    Andrew Misplon

    Thanks for your feedback 🙂 I’m unable to replicate the error on our demo site. Is Photon a module you would like to make use of? If so, perhaps I can login to your site and try troubleshoot this problem further. If not, we can leave it here.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Scroll to top