[Resolved] Featured image again

  • Author
  • #13760


    I’ve searched through the questions about featured images and don’t think I’m seeing the same issue I’m running into – I apologize if I missed the answer and am repeating.

    I am running Ultra Premium and Elementor Pro. In the theme settings under Pages, I have enabled (Display) Featured image and this works on the home page but when I go to the blog page itself, the featured image is not there. Editing the post I can insert the featured image as a block and that works fine until I go to the Category page that now shows the image twice which is not my intention. I am not seeing anything in Elementor Pro to block the featured image from being displayed and since you’ve been so helpful in the past, I thought I’d ask here first 🙂



    Andrew Misplon

    Hi Barry

    For posts, featured images should ideally be added in the right column using the traditional featured image setting.

    Theme settings for posts/archives are at Theme Settings > Blog:

    Archived Featured Image
    Post Featured Image

    If you do insert featured images manually using Elementor you could then adjust the theme display of those featured images using the above settings.



    Thank you! You solved that quite easily and of course, I’m a little embarrassed that I didn’t enable that in the correct place (blog).

    I didn’t realize this would actually cause a different, unrelated dilemma and I am off to find a solution for this. This being that when inserting the featured image manually using Elementor Pro, I was given the option to link the image to the original (full-sized) file – which is paramount because my posts are all about the image.

    It’s a totally different issue so I appreciate your help in solving my first question 🙂



    Actually…I tried to edit my last post because you did put the answer right in front of me…disabling featured image on the archive and blog pages is what I needed. Thanks again 🙂


    Andrew Misplon

    Super, really glad to hear you made progress and got things working as required. Cheers for now 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Scroll to top