Calendar widget is not loaded


  • Author
  • #3993



    I have added a calendar widget in the sidebar, using the Widget menu.
    With other themes, the widget calendar is displayed, but it doesn’t show when using Ultra Theme.
    Could you give a look please ?

    Ultra Theme 1.0.2
    Simple Calendar (Google calendar) 3.1.1

    You can see the issue here :

    Code :

    <div id="secondary" class="widget-area" role="complementary">
    <aside id="gce_widget-4" class="widget widget_gce_widget"></aside></div><!-- #secondary -->

    There is node code for calendar widget here.

    It only happens with this calendar widget. Search widget can be displayed. There must be some incompatibility between the theme and the plugin. The code isn’t even loaded in the html.

    Here is the beginning of the expected code :

    <h2 class="widget-title">Calendar</h2><div class="simcal-calendar simcal-default-calendar simcal-default-calendar-grid simcal-default-calendar-light" data-calendar-id="43" data-timezone="Europe/Paris" data-offset="7200" data-week-start="1" data-calendar-start="1467151200" data-calendar-end="1467669659" data-events-first="1467280800" data-events-last="1467669659">

    Have you had any issue like this before ?

    Thanks for your help.


    Andrew Misplon

    Hi arbeca

    Thanks for reaching out.

    Please, can you confirm that if you temporarily switch over to a default like Twenty Sixteen and add the specified calendar widget to the sidebar, does it immediately show?



    Thanks Andrew. Yes, I tried again with twenty sixteen, and it appears.
    This is only happening with Ultra theme.



    In the footer it is displayed. It only happens with the sidebar.


    Andrew Misplon

    Thanks for your feedback. It’s working normally on my local install, assuming I use the plugin’s widget. The shortcode doesn’t appear to work in a Text widget. How are you inserting your calendar? With the provided widget?

    Not sure if you ever use your browser’s developer console. If you open developer tools and click on the Console you’ll see the issue there. The plugin’s stylesheet can’t be found. Failed to load resource: net::ERR_CONNECTION_RESET

    I’m not sure why that’s happening, at least not yet. I don’t have the same error locally.

    Can you please try temporarily deactivating all other plugins. Does the issue persist?



    Wow this is extremely strange.

    1. I tried to inactivate the other plugins and it didn’t change anything. So I activated them again.
    2. I tried to add the widget from the left “personalize” sidebar instead of using the dashboard>appearance>widget menu, and it worked. So the issue was that adding the calendar from the dashboard didn’t work at first, but for some very strange reason, it works now, as if using the left sidebar (personalize) unblocked something.

    I cannot find an explanation why this happened… But it works !

    Thank you Andrew for looking into this, this is much apreciated !

    This is resolved now.


    Andrew Misplon

    Thanks for all of your feedback and testing, appreciate your help. I’m ok with that too, if it’s working for now we can move on. If a problem arises again with this widget or any other questions, please, let me know and I’ll help out.

    All the best with your site development 🙂 Cheers for now.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Scroll to top